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"Disable App Hibernation" or "Ignore Battery Optimizations" permission issues on Android 12 or higher

Information applies to:

Products
Panda Adaptive Defense 360 on Aether PlatformPanda Adaptive Defense on Aether Platform
Panda Dome for Android™ Panda Endpoint Protection Plus on Aether Platform

Symptoms
On Android 12 or higher, you may see warning messages on your WatchGuard Mobile Security/Panda Dome app requesting you to change the app hibernation or battery optimizations settings. However, when you check these settings on the device, they appear as recommended, but are greyed out and cannot be modified.


Cause
When a Device Admin permission is granted for an application, the status of the application's hibernate and battery optimization permissions is shown as disabled or unrestricted, although this is not actually the case, because Android does not show the actual status to the user and does not allow changing the status while the Device Admin permission is active.

Workaround/Solution
You need to disable Device admin for WatchGuard Mobile Security/Panda Dome, turn on and turn off the app hibernation and battery optimizations, and finally, re-enable Device admin for WatchGuard Mobile Security/Panda Dome. Follow these steps to solve the issue:
  1. Disable WatchGuard Mobile Security/Panda Dome from Device admin apps. Depending on the device vendor, the location might be different. For example:
    • Samsung: Settings > Security (or Biometrics and security)> Other security settings > Device admin apps.
    • Xiaomi: Settings > Privacy protection > Special permissions > Device admin apps.
    • Other: Settings > Apps > Special App Access > Device admin apps.
  2. Restart your Android device.
  3. Go to Settings > Apps, find WatchGuard Mobile Security/Panda Dome and apply these settings:
    • Select Battery and change the battery settings to No restrictions or Unrestricted.

    • In the App Info or App Permissions settings on the device, disable Remove permissions and free space or Pause app activity if unused. If it is shown as disabled, enable it and disable it again.

  4. Enable WatchGuard Mobile Security/Panda Dome from Device admin apps (same location as in Step 1).
If the problem persists, please contact Support.

Help nº- 20230519 700158 EN
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