Symptômes
L'erreur 4011 se produit lors de l'enregistrement d'un fichier de configuration de Panda Cloud Office Protection.
Cause
Une des règles de configuration de Panda Cloud Office Protection n'a pas pû être enregistrée. Cette situation peut être causée par des applications externes de filtrage de contenu, par exemple un firewall ou proxy, qui endommagent certains fichiers de configuration (règles).
Éléments à vérifier
- Assurez-vous que les règles associées à l'erreur sont dans leur répertoire :
WalSysCf chargé de l'enregistrement des règles de configuration de l'Agent (102,201,202,203,204,207) dans le dossier %ProgramFiles%\Panda Security\WaAgent\Common\Data\Cfg\WAC.
- Pour chacune des règles, le répertoire doit contenir un fichier du type suivant : {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX}203 avec X étant une partie du nom du fichier et 203 indiquant qu'il s'agit de la règle 203.
Solution
- Si l'erreur se produit pendant l'installation, l'agent doit être réinstallé.
Pour cela, relancez l'installeur téléchargé ou accédez à la console web et téléchargez-le à nouveau.
- Si l'agent est déjà installé, forcez le processus WalConf à s'exécuter une fois l'installation terminée. Pour cela :
- Accédez au dossier %ProgramFiles%\Panda Security\WaAgent\WasLpMng depuis une fenêtre DOS.
- Exécutez la commande waplpmng walconf -force
Données nécessaires pour rapporter l'incident
Si l'incident n'est pas résolu, vous devez recueillir un ensemble de données sur l'ordinateur. Ces informations seront recueillies de façon automatique par l'outil PSInfo que vous devez télécharger et exécuter en suivant ces instructions :
Depuis un ordinateur connecté à Internet, téléchargez le fichier
PSInfo2_V2.exe sur votre ordinateur et enregistrez-le sur le Bureau Windows.
Double-cliquez sur le fichier PSInfo2_V2.exe, afin que l'outil recueille des informations sur le matériel et les logiciels de votre ordinateur.
Remplissez tous les champs obligatoires.
Si PCOP est installé sur l'ordinateur, l'application PCOPDIAGS se lance.
Suivez les instructions de l'assistant de PCOPDIAGS.
Une fois la collecte de données terminées, un fichier appelé XXXX.psz est généré sur votre disque dur. Envoyez à Panda Security ce fichier qui est situé par défaut dans le dossier TEMP de votre disque dur.
Dans le cas où, pour quelque raison que ce soit, PSInfo ne peut pas être exécuté, ou si l'application PCOPDIAGS ne s'est pas lancée, vous devez recueillir et envoyer à Panda les données suivantes pour analyse :
- Le fichier journal WalSysCf (une fois l'erreur produite). Pour l'obtenir, effectuez les étapes suivantes :
- Trouvez le fichier WalSysCf.dat dans %Programfiles%\Panda Security\WaAgent\WalSysCf
- Éditez le fichier en ajoutant les lignes suivantes :
[LOG]
LevelLog=2000
- Redémarrez le service Panda Endpoint Administration Agent.
Pour reproduire l'erreur :
- Accédez au dossier %ProgramFiles%\Panda Security\WaAgent\WasLpMng depuis une fenêtre DOS.
- Exécutez la commande waplpmng walconf -force
Le fichier journal généré WalSysCf.log est enregistré dans le dossier %Programfiles%\Panda Security\WaAgent\WalSysCf
- L'ensemble du contenu du dossier %ProgramFiles%\Panda Security\WaAgent\Common\Data\Cfg\WAC.
Envoyez les données obtenues précédemment par email au service d'assistance technique de Panda Security pour analyse.