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Error 1799 in Panda Cloud Office Protection on-demand scans: one of the functions exported by the plug-in could not be loaded

Informatie van toepassing op:

Products
Panda Cloud Office Protection
Panda Cloud Office Protection Advanced

Symptoms

  • Error 1799 occurs on carrying out an on-demand scan from the Web administration console.

Cause

  • One of the functions exported by a plugin could not be loaded (see which plugin in the error message).
  • Incorrect installation or accidental deletion of a file.
  • Incompatible version of the plugin.
  • Corrupt file.

Elements to check

Check 1:The plugin file does not exist

  1. Check whether the plugin mentioned in the error message is included in the protection installation folder.
  2. Check that the plugin file is in that directory. If it is, go on to check 2.

Check 2:Incompatible version

In this case, you need to check that the plugin exports all the functions defined for the WalScan plugins (WA_Initialize, WA_Finalize, WA_GetPluginRevisions, WASCAN_StartScan).

  1. Edit the WalScan.ini file.
  2. Search for the plugin mentioned in the error message, in the [PLUGINS] section

    Example:
    [PLUGINS]
    WAC=C:\Program Files\Panda Security\WAC\WASCAN.dll
  3. Once you have found the plugin, check the program’s dependencies, i.e. Dependency Walker. In this example, the plugin is WASCAN.dll and it correctly exports the WASCAN_StartScan, WA_Finalize, WA_GetPluginRevisions, WA_Initialize functions, as you can see in the following image:

Solution

Apply the solution that corresponds to your case:

  • Copy the plugin that has caused the error in the correct directory.
  • Completely uninstall Panda Cloud Office Protection and reinstall it.

Data needed to report the incident

If the problem continues, send the following data to Panda:

  • WalScan configuration file (WalScan.ini).
    This file is in %Programfiles%\Panda Security\WaAgent\WalScan
  • WALScan log at detail level (once the error occurs).
    To get this log, follow the steps below:

    1. Edit the file and add the following lines:

      [LOG]
      LevelLog=2000
    2. Restart the Panda Endpoint Administration Agent service.
    3. For the error to reoccur and therefore collect the data, generate a new immediate scan and force an update for the scan to be launched. To do this:

      1. Run the command waplpmng walconf -force
      2. When the error reoccurs, collect the data and send it to Panda Security.


Artikelnummer- 20130103 501799 EN
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