Symptoms
On installing or updating the protection, or updating the Panda CloudOffice Protection communications agent, error 2112 occurs.
Cause
The protection installer or upgrader does not match the computer platform architecture (32 or 64-bit Edition).
This can happen if the agent incorrectly identified the system as 32 or 64 bits, or if the installation/upgrade was run manually from a downloaded package, and not using the installer for the right platform.
Elements to check
There are different protection installers for 32 and 64 bit versions of Windows. The right version for the actual platform must be used. If you are attempting to install or upgrade the protection with a package downloaded on another computer, note that they may have different architectures or that the architecture may not be supported.
To see a list of supported architectures and windows versions, please check the requirements necessary for running the installer are met.
Solution
Restart the installation and let the computer download the right installer for the protection.
Data needed to report the incident
If the issue is not solved, it is necessary to collect a series of data from the computer. This information is collected automatically by the PSInfo tool that you need to download and run following these instructions:
From a computer with Internet connection, download the
PSInfo2_V2.exe file into your computer and save it in your Windows Desktop.
Double click the PSInfo2_V2.exe file, so that the information about hardware and software from your computer is gathered.
Fill in all the requested fields.
If PCOP is installed in the computer, the PCOPDIAGS application will be launched.
Follow the PCOPDIAGS wizard.
When the data collection finishes, a file called XXXX.psz is generated in your hard drive. Send to Panda Security this file which is located in the TEMP folder of your hard drive, by default.
In the event that for whatever reason PSInfo cannot be run, or the PCOPDIAGS application has not been released, it is necessary to collect and send Panda the following data for analysis:
WalUpg log file (once the error occurs).
To get it, follow the steps below:
Find the WalUpg.ini file in %Programfiles%\Panda Security\WaAgent\WalUpg\WalUpg
Edit the file by adding the following lines:
[LOG]
LevelLog=2000
Restart the Panda Endpoint Administration Agent service.
To reproduce the error, bear in mind the moment in which the error occurred:
During protection installation:
Double-click the protection installer named PandaCloudEndpointProtectionxXX.msi, in %ProgramFiles%\Panda Security\WAC\WARepository\Installer
During protection update:
Try running the update process again: To do this:
Access the %ProgramFiles%\Panda Security\WaAgent\WasLpMng folder from a DOS window.
Run the command waplpmng walupg –force -continue
The log file generated, WALUPG.log, is saved in the folder %Programfiles%\Panda Security\WaAgent\WalUpg.
WalUpg.ini configuration file.
This file is in %ProgramFiles%\Panda Security\WaAgent\WalUpg
File retval.ini generated by the installer.
This file is in %Programfiles%\PandaSecurity\WaAgent\Common\DATA
WAC_Installer.log file.
This log file is generated in %Programfiles%\Panda Security\WaAgent\WalUpg when an error occurs.
Send the data previously obtained to the Panda Security tech support address for analysis.