Assistance Technique

Comment pouvons-nous vous aider ?

 

Erreur 1799 lors des analyses à la demande de Endpoint Protection : une des fonctions exportées par le plugin n'a pas pû être chargée

Ces informations s’appliquent à:

Produits
Endpoint Protection
Endpoint Protection Plus

Symptômes

  • L'erreur 1799 se produit lorsque des analyses à la demande sont effectuées depuis la console d'administration web.

Cause

  • Une des fonctions exportées par un plugin n'a pas pû être chargée (voir quel plugin dans le message d'erreur).
  • Installation incorrecte ou à suppression accidentelle d'un fichier.
  • Version du plugin incompatible.
  • Fichier corrompu.

Éléments à vérifier

Vérification n°1 : Le fichier plugin n'existe pas

  1. Vérifiez si le plugin mentionné dans le message d'erreur est inclus dans le dossier d'installation de la protection.
  2. Vérifiez que le fichier du plugin est dans ce dossier.Si tel est le cas, effectuez la deuxième vérification.

Vérification n°2 : Version incompatible

Dans ce cas, vous devez vérifier que le plugin exporte toutes les fonctions définies pour les plugins WalScan (WA_Initialize, WA_Finalize, WA_GetPluginRevisions, WASCAN_StartScan).

  1. Éditez le fichier WalScan.ini.
  2. Recherchez le plugin mentionné dans le message d'erreur dans la section [PLUGINS]

    Exemple :
    [PLUGINS]
    WAC=C:\Program Files\Panda Security\WAC\WASCAN.dll
  3. Une fois le plugin trouvé, vérifiez les dépendances du programme, c'est-à-dire Dependency Walker. Dans cet exemple, le plugin est WASCAN.dll et il exporte correctement les fonctions WASCAN_StartScan, WA_Finalize, WA_GetPluginRevisions, WA_Initialize functions, comme vous pouvez le voir dans la capture d'écran ci-dessous :

Solution

Appliquez la solution correspondant à votre situation :

  • Copiez le plugin causant l'erreur dans le bon dossier.
  • Désinstallez complètement Endpoint Protection et réinstallez-le.

Données nécessaires pour rapporter l'incident

If the issue is not solved, it is then necessary to collect a series of data from the computer. Please, read How to report problems from the Endpoint Protection console and follow the instructions indicated.

Numéro d`article d`aide- 20140519 501799 EN
TOUJOURS EN LIGNE POUR VOUS AIDER TWITTER FORUM
TOUJOURS EN LIGNE POUR VOUS AIDER TWITTER FORUM