Symptoms
Error 2130 is displayed when installing or upgrading the protection in Endpoint Protection.
Cause
This error occurs when:
There is an external interruption, such as, a sudden shut down of the system while installing, upgrading or uninstalling the protection.
Modifications are applied to the operating system; for instance, removing the Windows Installer cache to free disk space.
Solution
To delete the corrupted files that prevent the installation or upgrade of the protection you need to download and run the generic uninstaller of Endpoint Protection, and then proceed again with the installation of the protection.
Generic uninstaller
Generic uninstaller for version 7.xx
Once the requirements above are met, follow the steps below:
Unzip the contents to a folder (password panda).
First, run the DG_WAGENT_7_XX.exe file.
Restart the computer.
Next, run the protection uninstaller (DG_PAVPROT_7_XX.exe).
The uninstallation process may take a few minutes. Once completed, restart the computer.
Generic uninstaller for version 5.xx or lower
Once the requirements above are met, follow the steps below:
Unzip the contents to a folder (password panda).
Run the files in this order:
Firstly, the agent uninstaller (DG_WAGENT_5_50.exe).
Restart the computer.
Next, run the protection uninstaller (DG_WCLIENT_5_50.exe).
The uninstallation process may take a few minutes.
Once it is complete, restart the computer.