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Erreur 2081 lors de l’installation des protections de Panda Cloud Office Protection

Ces informations s’appliquent à:

Produits
Panda Cloud Office Protection
Panda Cloud Office Protection Advanced

Symptômes

L’erreur 2081 se produit lors de l’installation des protections de Panda Cloud Office Protection.

Cause

Cette erreur se produit pour une des raisons suivantes :

  • L’agent n’a pas terminé l’installation correctement et le fichier .msi est lancé. Une erreur est retournée au lancement du deuxième fichier .msi.
  • L’installeur a été corrompu par le firewall (par GateDefender ou une protection similaire qui a éliminé un fichier dans l’installeur .msi).
  • Infection de l’ordinateur par le virus Bagle.
  • Problèmes sur le PC avec d’autres installeurs, des virus, des spywares.

Solution

Panda Security a developpé l'outil 2081Fix.exe pour résoudre le code erreur 2081. Effectuez les étapes suivantes :

  1. Téléchargez et exécutez l'outil 2081Fix.exe.
  2. Effectuez les actions demandées par l'outil : par exemple, vérifier les droits administrateur pour résoudre un problème donné ou redémarrer le système.

    Note: Parfois, il est nécessaire de redémarrer le système et attendre que l'erreur 2081 se produise. Exécutez ensuite l'outil 2081Fix.

Vérifications complémentaires à effectuer pour confirmer ou infirmer la raison du problème

Si l'erreur 2081 persiste, effectuez les tests suivants pour confirmer ou infirmer la raison du problème.

Allez dans Démarrer -> Tous les programmes et assurez-vous qu’il n’y a AUCUN autre antivirus installé pouvant être désinstallé automatiquement. Vérifiez l’aide Quels programmes sont désinstallés automatiquement par Panda Cloud Office Protection.

  • Vérification 1 : Erreur générée par un autre installeur msi

    S’il s’est produit un problème avec le PC, vérifiez le fichier walupg.log, dans lequel devrait se trouver, en plus de l’erreur 2081, un autre numéro d’erreur sur une ligne précédente.

    Ce numéro d’erreur est retourné par défaut lors de l’installation d’un package .msi Microsoft.
    Vous trouverez plus d’informations concernant ces codes d’erreur sur le site de Microsoft aux adresses suivantes :

    http://msdn.microsoft.com/en-us/library/aa372835.aspx

    http://msdn.microsoft.com/en-us/library/aa368542(VS.85).aspx

    Ces problèmes peuvent être dus à l’échec de l’installation précédente d’un package .msi.

    Vérifiez aussi que les derniers drivers sont installés sur les appareils du réseau (Mon ordinateur - Gérer - Gestion des périphériques - Adaptateurs réseaux) et que aucun appareil du réseau n'est désactivé et/ou n'a des problèmes de reconnaissance (triangle jaune avec un point d'exclamation). Si tel est le cas, procédez à l'installation.
  • Vérification 2 : Installeur corrompu

    Vérifiez si un firewall est présent sur le réseau et assurez-vous, le cas échéant, qu’il ne bloque pas, totalement ou partiellement, le téléchargement de l’installeur .msi de la protection.

    L’installeur a pour nom “XXXXX_Panda Endpoint Protection x86.msi

    Par défaut, une fois l’installeur téléchargé, il se trouve à l’emplacement suivant :

    %ProgramFiles%\Panda Security\WAC\WARepository\Installer

    NOTE : Pour vous assurer que le fichier téléchargé n’est pas corrompu, essayez l’installeur sur un autre PC du réseau. Ce n’est pas problématique si Panda Cloud Office Protection est déjà installé sur cet ordinateur. Si tel est le cas, un message s’affiche indiquant que la protection est déjà installée.
  • Vérification 3 : Infection par Bagle

    Utilisez Windows Explorer pour aller dans le dossier %ProgramFiles%\Panda Security\WAC et créez un fichier TXT appelé PAVSRV51.EXE.

    Une fois créé, le fichier PAVSRV51.EXE devrait disparaître rapidement.

    Les fichiers créés par le virus Bagle incluent :
    • srosa.sys dans C:\Windows\System32\Drivers
    • wintems.exe dans C:\Windows\System32
    • hidr.exe dans C:\Windows\System32\Drivers

      Les variantes sont téléchargées dans le dossier C:\Windows\System32\Downl. Ce dossier contient de nombreux fichiers EXE.
  • Vérification 4 : Problèmes avec d’autres installeurs ou des virus

    Assurez-vous qu’aucune autre installation de produit n’est lancée.

    Effectuez une analyse complète de votre PC pour vous assurer qu’il n’y a pas de virus. Vous pouvez utiliser ActiveScan 2.0 pour cela.

Solution complémentaire

Appliquez la solution correspondant à votre situation :

  • Solution 1 : Infection par Bagle

    Désinfectez l’ordinateur. Vous pouvez utiliser ActiveScan 2.0 pour cela.
  • Solution 2 : Problèmes avec d’autres installeurs ou des virus

    Si l’installation d’un autre produit a été lancée, annulez-la.

    Dans le cas d’une infection, désinfectez l’ordinateur. Vous pouvez utiliser ActiveScan 2.0 pour cela.
  • Solution 3 : Installeur corrompu

    Résolvez le problème avec votre firewall et procédez à nouveau à l’installation.

    NOTE : Vous pouvez également copier l’installeur depuis un autre ordinateur sur lequel l’installation s’est effectuée correctement. Pour cela, allez dans %ProgramFiles%\Panda Security\WAC\WARepository\Installer
  • Solution 4 : Erreur générée par un autre installeur msi

    Contactez Microsoft pour résoudre les problèmes avec les installeurs msi.

Données nécessaires pour rapporter l’incident

If the issue is not solved, it is then necessary to collect a series of data from the computer. Please, read How to report problems from the Panda Cloud Office Protection console and follow the instructions indicated.

Numéro d`article d`aide- 20140519 502081 EN
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