Du är här : Panda Security > IT Security for Business > support > Soporte Productos Panda Security

Vad vill du ha hjälp med?
(Exempel:"Panda AdminSecure", "2093 error")

Error 2122 updating the protection or the Endpoint Protection agent

Informationen gäller för:

Endpoint Protection
Endpoint Protection Plus


Error 2122 occurs updating the protection or the Endpoint Protection communications agent.


The WalUpg.ini configuration file is incomplete. The URL_WEB_GUID entry in the GENERAL section of file %ProgramFiles%\Panda Security\WaAgent\WalUpg\WALUpg.ini cannot be read.

Elements to check

Check whether the WALUpg.ini configuration file exists in the relevant folder. To do this, follow the steps below:

  1. Go to %ProgramFiles%\Panda Security\WaAgent\WalUpg
  2. Make sure the WALUpg.ini file exists in that directory.
  3. Open the WALUpg.ini file and check it includes an entry similar to http://enterprise.updates.pandasoftware.com/updates_ent/lastupgrade_default_XX_X_XX.html


Copy the WALUpg.ini file from another computer to the directory %ProgramFiles%\Panda Security\WaAgent\WalUpg of the affected computer.

If problem persists:

  1. Uninstall the agent using the Add or Remove Programs option.
    NOTE: You don’t need to uninstall the protection.
  2. Download and run the installer again from the Endpoint Protection console.
  3. The program will be installed and will detect if the protection is installed or not or whether it needs updating.

Data needed to report the incident

If the issue is not solved, it is then necessary to collect a series of data from the computer. Please, read How to report problems from the Endpoint Protection console and follow the instructions indicated.

Artikelnummer- 20140630 502122 EN

Hjälp oss att förbättra vår service genom att låta oss veta din åsikt.

Dina förslag hjälper till att lösa dina frågor snabbare och effektivare.

Har ditt problem lösts med hjälp av denna artikel? JA NEJ Thanks for your answer

Hur skulle du förbättra denna artikel?

Vill du kontakta teknisk support?