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Error 1799 durante un análisis bajo demanda de Endpoint Protection: no se ha podido cargar alguna de las funciones exportadas por el plugin

Información aplicable a:

Productos
Endpoint Protection
Endpoint Protection Plus

Síntomas

Al realizar un análisis bajo demanda desde la consola Web de administración se muestra el error 1799.

Causas

  • No se ha podido cargar alguna de las funciones exportadas por el plugin reflejado en el error.
  • Posible instalación errónea o borrado accidental de algún fichero.
  • Versión incompatible del plugin.
  • Fichero corrupto.

Comprobaciones a realizar

Comprobación 1: El archivo de plugin no existe

  1. El archivo de plugin existe en el directorio de instalación.
    Compruebe que el plugin indicado en el mensaje de error existe dentro de la carpeta de instalación de la protección. Para ello:
    1. Acceda a %ProgramFiles%\Panda Security\WAC.
    2. Verifique que el archivo del plugin indicado en el mensaje de error se encuentra en dicho directorio. Si efectivamente el archivo existe, continúe con la siguiente comprobación.

  2. La versión del plugin se ha instalado correctamente

    Compruebe que el plugin exporta todas las funciones definidas para los plugins de WalScan (WA_Initialize, WA_Finalize, WA_GetPluginRevisions, WASCAN_StartScan). Para ello:

    1. Acceda al directorio %ProgramFiles%\Panda Security\WaAgent\WalScan.
    2. Edite el archivo WalScan.ini.
    3. Localice el plugin del mensaje de error en la sección [PLUGINS]
    Ejemplo:

    [PLUGINS]
    WAC=C:\Archivos de programa\Panda Security\WAC\WASCAN.dll

    4. Una vez localizado el plugin, es necesario ver sus dependencias con un programa como por ejemplo, Dependency Walker. En este ejemplo, el plugin es WASCAN.dll, y exporta correctamente las funciones WASCAN_StartScan, WA_Finalize, WA_GetPluginRevisions, WA_Initialize


Comprobación 2: Versión incompatible

En este caso, será necesario comprobar que el plugin exporta todas las funciones definidas para los plugins de WalScan (WA_Initialize, WA_Finalize, WA_GetPluginRevisions, WASCAN_StartScan).

  1. Acceda al directorio %ProgramFiles%\Panda Security\WaAgent\WalScan.
  2. Edite el archivo WalScan.ini.
  3. Localice el plugin del mensaje de error en la sección [PLUGINS]

    Ejemplo:
    [PLUGINS]
    WAC=C:\Archivos de programa\Panda Security\WAC\WASCAN.dll
  4. Una vez localizado el plugin, es necesario ver sus dependencias con un programa como por ejemplo, Dependency Walker. En este ejemplo, el plugin es WASCAN.dll, y exporta correctamente las funciones WASCAN_StartScan, WA_Finalize, WA_GetPluginRevisions, WA_Initialize, como se puede observar en la siguiente imagen:

Solución

Siga las siguientes instrucciones:

  1. Si el archivo de plugin no existe en el directorio de instalación, copie el plugin causante del fallo en el directorio apropiado (%ProgramFiles%\Panda Security\WAC)
  2. Si la versión del plugin no se ha instalado correctamente, desinstale de forma completa Panda Cloud Office Protection y vuelva a instalarlo de nuevo.

Datos necesarios para reportar la incidencia

En el caso de no solucionarse la incidencia, es necesario recoger una serie de datos del equipo. Lea por favor el artículo Cómo notificar una incidencia desde la consola de Endpoint Protection y siga los pasos indicados.

Ayuda nº- 20140519 501799 ES
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