Soporte técnico

¿Necesitas ayuda?

 

Errores de configuración de permisos en "Ignorar optimizaciones de batería" y "Deshabilitar Hibernación de App" en Android 12 o superior

Información aplicable a:

Productos
Panda Adaptive Defense 360 on Aether PlatformPanda Adaptive Defense on Aether Platform
Panda Dome for Android™ Panda Endpoint Protection Plus on Aether Platform

Síntomas
En Android 12 o superior, es posible que aparezcan mensajes de advertencia en tu aplicación WatchGuard Mobile Security/Panda Dome solicitándote que modifiques los ajustes de hibernación y/o optimización de la batería de la aplicación. Sin embargo, al comprobar los ajustes en el dispositivo, las opciones de configuración aparecen como se recomienda en el mensaje de advertencia, pero están en gris y no se pueden modificar.


Causa
Cuando se concede un permiso de administrador del dispositivo para una aplicación, el estado de los permisos de hibernación de la aplicación y optimización de la batería se muestra como desactivado o sin restricciones, aunque en realidad no es así, porque Android no muestra el estado real al usuario y además no permite cambiar el estado mientras esté el permiso de Administrador de dispositivos activo.

Solución
Desactiva el Administrador de dispositivos para WatchGuard Mobile Security/Panda Dome, activa y desactiva las optimizaciones de batería y la hibernación de la aplicación y, por último, vuelve a activar Administrador de dispositivos para WatchGuard Mobile Security/Panda Dome. Sigue estos pasos para resolver el problema:
  1. Desactiva WatchGuard Mobile Security/Panda Dome desde Aplicaciones del administrador de dispositivos. En función del fabricante, la ubicación variará. Pro ejemplo:
    • Samsung: Ajustes > Securidad (o Biométrica y Seguridad)> Otros ajustes de seguridad > Aplicaciones del administrador de dispositivos.
    • Xiaomi: Ajustes > Protección de privacidad > Permisos especiales > Aplicaciones del administrador de dispositivos.
    • Other: Ajustes > Apps > Acceso especial de app > Aplicaciones del administrador de dispositivos.
  2. Reinicia tu dispositivo Android.
  3. Accede a Ajustes > Apps, localiza WatchGuard Mobile Security/Panda Dome y aplica estos ajustes:
    • Selecciona Batería y configura los ajustes de batería como Sin restricciones.

    • En la configuración de la opción Información de aplicación o Permisos de aplicación, desactiva Eliminar permisos y liberar espacio o Pausar actividad de la aplicación si no se usa. En caso de aparecer desactivada, actívala y vuelve a dejarla desactivada.

  4. Activa nuevamente WatchGuard Mobile Security/Panda Dome desde Aplicaciones del administrador de dispositivos (en la misma ruta que el paso 1).
Si el problema persiste, contacta con Soporte.

Ayuda nº- 20230515 700158 ES
SIEMPRE ONLINE PARA AYUDARTE TWITTER FORO

Contacta con nuestros técnicos:

Escribe un email
SIEMPRE ONLINE PARA AYUDARTE TWITTER FORO

¿Eres un Partner o cliente de WatchGuard y necesitas ayuda con los productos Panda?

+ Info