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Error 3333 en la carga/descarga de los plugins durante la actualización del archivo de identificadores de Endpoint Protection

Información aplicable a:

Productos
Endpoint Protection
Endpoint Protection Plus

Síntomas

Error 3333 al realizarse la carga o descarga de los plugins durante la actualización del archivo de identificadores de Endpoint Protection.

Causas

El log WalUpd.log ubicado en %ProgramFiles%\Panda Security\WaAgent\WalUpd marca los siguientes posibles errores:

  • EC_WALUPD_ERR_NULL_ARG (2048). Indica que la ruta de carga del plugin es una cadena vacía dentro de la sección PLUGINS del archivo WalUpd.ini, por ejemplo:
    [PLUGINS]
    WAAGENT=" "
  • EC_WALUPD_ERR_GENERAL (2049). Indica que el path al plugin es incorrecto, o que éste ya no se encuentra en la ubicación señalada en la sección PLUGINS del fichero WalUpd.ini. También puede ser un indicio de que el fichero está corrupto.
  • EC_WALUPD_ERR_COULD_NOT_LOAD_PLUGIN (2053). Indica que la librería no exporta las funciones que se necesitan.

Comprobaciones a realizar

  • Comprobación 1: Las librerías existen en los directorios.

    Es necesario comprobar que:
    • Todas las librerías que aparecen en la sección PLUGINS del fichero WALUpd.ini existen en los directorios que se indican.
    • Que estos directorios no se encuentran vacíos.

      Si, efectivamente, las librerías existen en los directorios y estos no se encuentran vacíos, continúe con la siguiente comprobación.
  • Comprobación 2: Versión incompatible.

    En este caso, será necesario comprobar que todos los plugin registrados en la sección PLUGINS del fichero WalUpd.ini exportan todas las funciones definidas para los plugins de Walupd (WA_Initialize, WA_Finalize, WA_GetPluginRevisions, WASFUPD_GetSFTypesCount, WASFUPD_GetSFTypeByIndex, WASFUPD_GetSFSubTypesCount, WASFUPD_GetSFSubTypeByIndex, WASFUPD_GetSFInfo, WASFUPD_GetSFPath, WASFUPD_UpdateSFByPath).

    Para ello:

    1. Acceda al directorio %ProgramFiles%\Panda Security\WaAgent\WalUpd.
    2. Edite el archivo WalUpd.ini.
    3. Localice todos los plugins registrados en la sección [PLUGINS]
      Ejemplo:
      [PLUGINS]
      WAAGENT="C:\Archivos de programa\Panda Security\WaAgent\WALSYSUD\WalSysUd.dll"
      WAC=C:\Archivos de programa\Panda Security\WAC\WAUPD.dll
    4. Una vez localizado el plugin, es necesario ver sus dependencias con un programa como, por ejemplo, Dependency Walker.

      En este ejemplo, el plugin es WAUPD.dll, y exporta correctamente las funciones WA_Initialize, WA_Finalize, WA_GetPluginRevisions, WASFUPD_GetSFTypesCount, WASFUPD_GetSFTypeByIndex, WASFUPD_GetSFSubTypesCount, WASFUPD_GetSFSubTypeByIndex, WASFUPD_GetSFInfo, WASFUPD_GetSFPath y WASFUPD_UpdateSFByPath., como se puede observar en la siguiente imagen:


Solución

Según el caso del que se trate, aplique las siguientes soluciones:

  1. Copie el plugin causante del fallo en el directorio apropiado.
  2. Modifique el path para que apunte al fichero adecuado.
    • Si alguna librería ya no existe, debido a la desinstalación de una protección, puede eliminar la entrada correspondiente de la sección PLUGINS del fichero WALUpd.ini.
    • Si la librería está pero no exporta las funciones necesarias, sustituya la librería por una versión correcta de la misma o reinstale la protección.

Datos necesarios para reportar la incidencia

En el caso de no solucionarse la incidencia, es necesario recoger una serie de datos del equipo. Lea por favor el artículo Cómo notificar una incidencia desde la consola de Endpoint Protection y siga los pasos indicados.

Ayuda nº- 20140701 503333 ES
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