Symptoms
- Error 1799 occurs on carrying out an on-demand scan from the Web administration console.
Cause
- One of the functions exported by a plugin could not be loaded (see which plugin in the error message).
- Incorrect installation or accidental deletion of a file.
- Incompatible version of the plugin.
- Corrupt file.
Elements to check
Check 1:The plugin file does not exist
- Check whether the plugin mentioned in the error message is included in the protection installation folder.
- Check that the plugin file is in that directory. If it is, go on to check 2.
Check 2:Incompatible version
In this case, you need to check that the plugin exports all the functions defined for the WalScan plugins (WA_Initialize, WA_Finalize, WA_GetPluginRevisions, WASCAN_StartScan).
- Edit the WalScan.ini file.
- Search for the plugin mentioned in the error message, in the [PLUGINS] section
Example:
[PLUGINS]
WAC=C:\Program Files\Panda Security\WAC\WASCAN.dll - Once you have found the plugin, check the program’s dependencies, i.e. Dependency Walker. In this example, the plugin is WASCAN.dll and it correctly exports the WASCAN_StartScan, WA_Finalize, WA_GetPluginRevisions, WA_Initialize functions, as you can see in the following image:
Solution
Apply the solution that corresponds to your case:
- Copy the plugin that has caused the error in the correct directory.
- Completely uninstall Endpoint Protection and reinstall it.
Data needed to report the incident
If the issue is not solved, it is then necessary to collect a series of data from the computer. Please, read How to report problems from the Endpoint Protection console and follow the instructions indicated.