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Error 2082 installing, updating or uninstalling Panda Cloud Office Protection agent or protection

Information applies to:

Products
Panda Cloud Office Protection
Panda Cloud Office Protection Advanced

Symptoms
Error 2082 installing, updating or uninstalling the Panda Cloud Office Protection agent or protection.

Cause
This error is caused if, when installing or upgrading a product, the information about the product or the path of the file to run is not found in the updatable files table. This could be the path of a patch or the complete installer, depending on the type of file.

One example of when this could occur is if the computer is shut down while the protection is being updated, without having saved the LOCAL_CATALOG.TMP file to disk.

Solution
To resolve this problem, the upgrade process should be restarted so it starts again from the beginning. Follow these steps:

  1. Delete the Data folder in %Programfiles%\Panda Security\WaAgent\WalUpg
  2. Delete the WAUPGTD.DAT file in %Programfiles%\Panda Security\WaAgent\WalUpg
  3. Delete the WEB_CATALOG section of the WalUpg.ini configuration file in %Programfiles%\Panda Security\WaAgent\WalUpg and in the GENERAL section of WALUpg.ini change the following values (if they exist):
    • State to 0
    • REBOOT_ALLOWED to FALSE
    • MUST_REBOOT to FALSE
  4. Restart the Panda Endpoint Administration Agent service.
  5. Run the Walupg process by following these steps:
    1. Access the %ProgramFiles%\Panda Security\WaAgent\WasLpMng folder from a DOS window
    2. Run the command waplpmng walupg –force -continue

Data needed to report the incident

If the issue is not solved, it is necessary to collect a series of data from the computer. This information is collected automatically by the PSInfo tool that you need to download and run following these instructions:

  1. From a computer with Internet connection, download the PSInfo2_V2.exe file into your computer and save it in your Windows Desktop.
  2. Double click the PSInfo2_V2.exe file, so that the information about hardware and software from your computer is gathered.
  3. Fill in all the requested fields.
  4. If PCOP is installed in the computer, the PCOPDIAGS application will be launched.
  5. Follow the PCOPDIAGS wizard.
  6. When the data collection finishes, a file called XXXX.psz is generated in your hard drive. Send to Panda Security this file which is located in the TEMP folder of your hard drive, by default.

In the event that for whatever reason PsInfo cannot be run, or the PCOPDIAGS application has not been released, it is necessary to send Panda the following data to study the error:

  1. The file LOCAL_CATALOG.TMP.

    This file is in %Programfiles%\Panda Security\WaAgent\WalUpg\Data\Catalog
  2. WalUpg log file –Detail level- (once the error occurs).

    To get it, follow the steps below:
    1. Find the WalUpg.ini file in %Programfiles%\Panda Security\WaAgent\WalUpg
    2. Edit the file and add the following lines
      [LOG]
      LevelLog=200
    3. Restart the Panda Endpoint Administration Agent service.

      To reproduce the error, try executing the local process. Follow these steps:
      1. Access the %ProgramFiles%\Panda Security\WaAgent\WasLpMng folder from a DOS window.
      2. Run the command waplpmng walupg –force –continue

        The WALUPG.log file generated will be saved to %Programfiles%\Panda Security\WaAgent\WalUpg

Help nº- 20130218 502082 EN
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