Symptômes
Erreur 2082 lors de l'installation, la mise à jour ou la désinstallation de l'agent ou de la protection de Panda Cloud Office Protection.
Cause
Cette erreur se produit si, pendant l'installation ou la mise à niveau du produit, les informations sur le produit ou le chemin du fichier à exécuter ne sont pas trouvées dans la table des fichiers actualisables. Il peut s'agir du chemin d'un correctif ou de l'installeur complet, suivant le type de fichier.
Par exemple, cela peut se produire lorsque l'ordinateur est éteint pendant la mise à jour de la protection, sans que le fichier LOCAL_CATALOG.TMP ait été enregistré sur le disque.
Solution
Pour résoudre ce problème, le processus de mise à niveau doit être redémarré afin qu'il recommence depuis le début. Effectuez les étapes suivantes :
Supprimez le dossier Data dans %Programfiles%\Panda Security\WaAgent\WalUpg
Supprimez le fichier WAUPGTD.DAT dans %Programfiles%\Panda Security\WaAgent\WalUpg
Supprimez la section WEB_CATALOG du fichier de configuration WalUpg.ini dans %Programfiles%\Panda Security\WaAgent\WalUpg et dans la section GENERAL de WALUpg.ini changez les valeurs suivantes (si elles sont présentes) :
State à 0
REBOOT_ALLOWED sur FALSE
MUST_REBOOT sur FALSE
Redémarrez le service Panda Endpoint Administration Agent.
Exécutez le processus Walupg en effectuant les étapes suivantes :
Accédez au dossier %ProgramFiles%\Panda Security\WaAgent\WasLpMng depuis une fenêtre DOS
Exécutez la commande waplpmng walupg -force –continue
Données nécessaires pour rapporter l'incident
Si l'incident n'est pas résolu, vous devez recueillir un ensemble de données sur l'ordinateur. Ces informations seront recueillies de façon automatique par l'outil PSInfo que vous devez télécharger et exécuter en suivant ces instructions :
Depuis un ordinateur connecté à Internet, téléchargez le fichier
PSInfo2_V2.exe sur votre ordinateur et enregistrez-le sur le Bureau Windows.
Double-cliquez sur le fichier PSInfo2_V2.exe, afin que l'outil recueille des informations sur le matériel et les logiciels de votre ordinateur.
Remplissez tous les champs obligatoires.
Si PCOP est installé sur l'ordinateur, l'application PCOPDIAGS se lance.
Suivez les instructions de l'assistant de PCOPDIAGS.
Une fois la collecte de données terminée, un fichier appelé XXXX.psz est généré sur votre disque dur. Envoyez à Panda Security ce fichier, qui est situé par défaut dans le dossier TEMP de votre disque dur.
Dans le cas où, pour quelque raison que ce soit, PSInfo ne peut pas être exécuté, ou si l'application PCOPDIAGS ne s'est pas lancée, vous devez recueillir et envoyer à Panda les données suivantes pour étudier l'erreur :
Le fichier LOCAL_CATALOG.TMP.
Ce fichier est dans %Programfiles%\Panda Security\WaAgent\WalUpg\Data\Catalog
Le fichier journal WalUpg détaillé (une fois l'erreur produite).
Pour l'obtenir, effectuez les étapes suivantes :
Trouvez le fichier WalUpg.ini, situé dans %Programfiles%\Panda Security\WaAgent\WalUpg
Éditez le fichier en ajoutant les lignes suivantes
[LOG]
LevelLog=200
Redémarrez le service Panda Endpoint Administration Agent.
Pour reproduire l'erreur, essayez de lancer le processus local. Effectuez les étapes suivantes :
Accédez au dossier %ProgramFiles%\Panda Security\WaAgent\WasLpMng depuis une fenêtre DOS.
Exécutez la commande waplpmng walupg –force –continue
Le fichier journal généré, WALUPG.log, est enregistré dans le dossier %Programfiles%\Panda Security\WaAgent\WalUpg