Síntomas
Error 2082 durante la instalación, actualización o desinstalación de las protecciones o agente de Panda Cloud Office Protection.
Causas
Este error se da en el caso de que al proceder a la instalación o upgrade de un producto, no se encuentra en la tabla de ficheros actualizables la información para ese producto, o bien si no se encuentra en la tabla el path del fichero a ejecutar. Puede tratarse del path de un parche o del instalador completo, según el tipo de fichero que se haya obtenido.
Un ejemplo en el que ocurriría esto sería que se apagase la máquina en medio del proceso de actualización de las protecciones, sin que se haya llegado a guardar en disco el fichero LOCAL_CATALOG.TMP.
Solución
Para solucionar la incidencia hay que reiniciar el proceso de upgrade para que comience desde el principio. Para ello:
Borrar el directorio Data en %Programfiles%\Panda Security\WaAgent\WalUpg
Borrar el fichero WAUPGTD.DAT en %Programfiles%\Panda Security\WaAgent\WalUpg
Borrar la sección WEB_CATALOG del fichero de configuración WalUpg.ini en %Programfiles%\Panda Security\WaAgent\WalUpg y en la sección GENERAL del WALUpg.ini cambiar, si existen, los siguientes valores:
State a 0
REBOOT_ALLOWED a FALSE
MUST_REBOOT a FALSE
Reiniciar el servicio Panda Endpoint Administration Agent.
Ejecutar el proceso Walupg siguiendo estos pasos:
Acceda desde una ventana de DOS a la carpeta %ProgramFiles%\Panda Security\WaAgent\WasLpMng
Ejecute el comando waplpmng walupg –force –continue
Datos necesarios para reportar la incidencia
En el caso de no solucionarse la incidencia, es necesario recoger una serie de datos del equipo. Estos datos son recogidos automáticamente por la herramienta PSINFO que deberá descargar y ejecutar siguiendo estas instrucciones:
Desde un equipo con conexión a Internet, descargue el fichero
PSInfo2_V2.exe y guárdelo en el Escritorio de Windows.
Haga doble clic sobre el fichero PSInfo2_V2.exe para que éste pueda recoger la información necesaria del equipo.
Rellene los datos solicitados.
Si PCOP está instalado en el equipo, se lanzará la aplicación PCOPDIAGS (Diagnósticos PCOP).
Siga los pasos del asistente de PCOPDIAGS.
Cuando finalice la recogida de datos, se generará en su equipo un fichero llamado XXXX.psz que deberá remitir a Panda Security.
En el caso de que por cualquier motivo no pueda ejecutar el PSINFO, o que no se haya lanzado la aplicación PCOPDIAGS, será necesario remitir a Panda los siguientes datos para su estudio:
El fichero LOCAL_CATALOG.TMP. Este fichero se encuentra en %Programfiles%\Panda Security\WaAgent\WalUpg\Data\Catalog
Fichero de log de WalUpg a nivel detalle, una vez que se vuelva a producir el error. Para obtener estos datos, siga los siguientes pasos:
Localice el fichero WalUpg.ini ubicado en %Programfiles%\Panda Security\WaAgent\WalUpg
Edite el fichero y escriba las siguientes líneas:
[LOG]
LevelLog=200
A continuación, reinicie el servicio Panda Endpoint Administration Agent.
Para que se vuelva a producir el error reintente la ejecución del proceso local. Para ello:
Acceda desde una ventana de DOS a la carpeta %ProgramFiles%\Panda Security\WaAgent\WasLpMng
Ejecute el comando waplpmng walupg –force –continue
El fichero del log generado WALUPG.log se guardará en la carpeta %Programfiles%\Panda Security\WaAgent\WalUpg