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Error 2111 installing or updating the protection, or updating the Panda Cloud Office Protection

Information applies to:

Products
Panda Cloud Office Protection
Panda Cloud Office Protection Advanced

Symptoms

On installing or updating the protection, or updating the Panda Cloud Office Protection communications agent, error 2111 occurs.

Cause

Insufficient disk space.

Elements to check

Check whether the disk space requirements for running the installer are met.

Solution

If there is insufficient disk space, free up disk space.

Data needed to report the incident

If the issue is not solved, it is necessary to collect a series of data from the computer. This information is collected automatically by the PSInfo tool that you need to download and run following these instructions:

  1. From a computer with Internet connection, download the PSInfo2_V2.exe file into your computer and save it in your Windows Desktop.
  2. Double click the PSInfo2_V2.exe file, so that the information about hardware and software from your computer is gathered.
  3. Fill in all the requested fields.
  4. If PCOP is installed in the computer, the PCOPDIAGS application will be launched.
  5. Follow the PCOPDIAGS wizard.
  6. When the data collection finishes, a file called XXXX.psz is generated in your hard drive. Send to Panda Security this file which is located in the TEMP folder of your hard drive, by default.

In the event that for whatever reason PsInfo cannot be run, or the PCOPDIAGS application has not been released, it is necessary to collect the following data for analysis:

  1. WalUpg log file (once the error occurs).

    To get it, follow the steps below:

    1. Find the WalUpg.ini file in %Programfiles%\Panda Security\WaAgent\WalUpg\WalUpg
    2. Edit the file by adding the following lines:

      [LOG]
      LevelLog=2000
    3. Restart the Panda Endpoint Administration Agent service.

      To reproduce the error, bear in mind the moment in which the error occurred:

      • During protection installation:

        Double-click the protection installer named PandaCloudEndpointProtectionxXX.msi, in %ProgramFiles%\Panda Security\WAC\WARepository\Installer
      • During protection update:

        Try running the update process again: To do this:

        1. Access the %ProgramFiles%\Panda Security\WaAgent\WasLpMng folder from a DOS window.
        2. Run the command waplpmng walupg –force -continue

          The log file generated, WALUPG.log, is saved in the folder %Programfiles%\Panda Security\WaAgent\WalUpg.
  2. WalUpg.ini configuration file.
    This file is in %ProgramFiles%\Panda Security\WaAgent\WalUpg
  3. File retval.ini generated by the installer.
    This file is in %Programfiles%\PandaSecurity\WaAgent\Common\DATA
  4. WAC_Installer.log file.
    This log file is generated in %Programfiles%\Panda Security\WaAgent\WalUpg when an error occurs.

Send the data previously obtained to the Panda Security tech support address for analysis.

Help nº- 20130103 502111 EN
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