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Erreur 3333 lors du chargement/téléchargement de plugins pendant la mise à jour du fichier de signatures de Panda Cloud Office Protection

Ces informations s’appliquent à:

Produits
Panda Cloud Office Protection
Panda Cloud Office Protection Advanced

Symptômes

Erreur 3333 lors du chargement/téléchargement de plugins pendant la mise à jour du fichier de signatures de Panda Cloud Office Protection.

Cause

Le fichier WalUpd.log dans %ProgramFiles%\Panda Security\WaAgent\WalUpd rapporte les erreurs suivantes :

  • EC_WALUPD_ERR_NULL_ARG (2048). Cela signifie que le chemin de chargement du plugin est un champ vide dans la section PLUGINS du fichier WalUpd.ini. Par exemple :
    [PLUGINS]
    WAAGENT=" "
  • EC_WALUPD_ERR_GENERAL (2049). Cela signifie que le chemin du plugin est incorrect ou que le plugin n'est pas trouvé à l'emplacement spécifié dans la section PLUGINS du fichier WalUpd.ini. Cela peut aussi signifier que le fichier est corrompu.
  • EC_WALUPD_ERR_COULD_NOT_LOAD_PLUGIN (2053). Cela signifie que la bibliothèque n'exporte pas les fonctions nécessaires.

Éléments à vérifier

  • Vérification n°1 : Les bibliothèques existent effectivement dans les chemins.

    Effectuez les étapes suivantes :
    1. Toutes les bibliothèques mentionnées dans la section PLUGINS du fichier WALUpd.ini sont effectivement présentes dans les chemins indiqués.
    2. Ces chemins ne sont pas vides.

      Si les bibliothèques sont présentes dans les chemins spécifiés et qu'ils ne sont pas vides, effectuez la vérification suivante.
  • Vérification n°2 : Version incompatible.

    Dans ce cas, il faut vérifier que tous les plugins enregistrés dans la section PLUGINS du fichier WalUpd.ini exportent toutes les fonctions définies pour les plugins Walupd (WA_Initialize, WA_Finalize, WA_GetPluginRevisions, WASFUPD_GetSFTypesCount, WASFUPD_GetSFTypeByIndex, WASFUPD_GetSFSubTypesCount, WASFUPD_GetSFSubTypeByIndex, WASFUPD_GetSFInfo, WASFUPD_GetSFPath, WASFUPD_UpdateSFByPath).
    1. Allez dans le dossier %ProgramFiles%\Panda Security\WaAgent\WalUpd.
    2. Editez le fichier WalUpd.ini.
    3. Trouvez tous les plugins enregistrés dans la section [PLUGINS]

      Exemple :
      [PLUGINS]
      WAAGENT="C:\Program Files\Panda Security\WaAgent\WALSYSUD\WalSysUd.dll"
      WAC=C:\Program Files\Panda Security\WAC\WACONF.dll
    4. Une fois que vous avez trouvé le plugin, vérifiez ses dépendances en utilisant un outil tel que Dependency Walker par exemple.

      Dans cet exemple, le plugin est WAUPD.dll et il exporte correctement les fonctions suivantes : WA_Initialize, WA_Finalize, WA_GetPluginRevisions, WASFUPD_GetSFTypesCount, WASFUPD_GetSFTypeByIndex, WASFUPD_GetSFSubTypesCount, WASFUPD_GetSFSubTypeByIndex, WASFUPD_GetSFInfo, WASFUPD_GetSFPath et WASFUPD_UpdateSFByPath, comme vous pouvez le voir dans l'image ci-dessous :

Solution

Appliquez la solution correspondant à votre situation :

  1. Copiez le plugin causant l'erreur dans le bon dossier.
  2. Modifiez le chemin pour qu'il pointe vers le bon fichier.
    • Si certaines bibliothèques n'existent pas, car un module de protection a été désinstallé, vous pouvez supprimer l'entrée correspondante de la section PLUGINS du fichier WALUpd.ini.
    • Si la bibliothèqie est présente mais qu'elle n'exporte pas toutes les fonctions nécessaires, remplacez la bibliothèque par une version correcte ou réinstallez la protection.

Données nécessaires pour rapporter l'incident

Si l'incident n'est pas résolu, vous devez recueillir un ensemble de données sur l'ordinateur. Ces informations seront recueillies de façon automatique par l'outil PSInfo que vous devez télécharger et exécuter en suivant ces instructions :

  1. Depuis un ordinateur connecté à Internet, téléchargez le fichier PSInfo2_V2.exe sur votre ordinateur et enregistrez-le sur le Bureau Windows.
  2. Double-cliquez sur le fichier PSInfo2_V2.exe, afin que l'outil recueille des informations sur le matériel et les logiciels de votre ordinateur.
  3. Remplissez tous les champs obligatoires.
  4. Si PCOP est installé sur l'ordinateur, l'application PCOPDIAGS se lance.
  5. Suivez les instructions de l'assistant de PCOPDIAGS.
  6. Une fois la collecte de données terminée, un fichier appelé XXXX.psz est généré sur votre disque dur. Envoyez à Panda Security ce fichier, qui est situé par défaut dans le dossier TEMP de votre disque dur.

Dans le cas où, pour quelque raison que ce soit, PSInfo ne peut pas être exécuté, ou si l'application PCOPDIAGS ne s'est pas lancée, vous devez recueillir et envoyer à Panda les données suivantes pour analyse :

  1. Le fichier de configuration WalUpd.ini.

    Ce fichier est situé dans %Programfiles%\Panda Security\WaAgent\Security\WaAgent\WalUpd
  2. Le fichier journal WalUpd (une fois l'erreur produite).

    Pour obtenir ce fichier journal, effectuez les étapes suivantes :
    1. Trouvez le fichier WalUpd.ini dans %ProgramFiles%\Panda Security\WaAgent\WalUpd
    2. Éditez le fichier en ajoutant les lignes suivantes
      [LOG]
      LevelLog=200
    3. Redémarrez le service Panda Endpoint Administration Agent.

      Pour que l'erreur se reproduise et que vous puissiez recueillir les données, générez une analyse immédiate et forcez une mise à jour pour lancer l'analyse. Pour cela :
      1. Accédez au dossier %ProgramFiles%\Panda Security\WaAgent\WasLpMng depuis une fenêtre DOS
      2. Exécutez la commande waplpmng walupd -force –continue

Une fois l'erreur reproduite, recueillez les données et envoyez-les à Panda Security.


Numéro d`article d`aide- 20130204 503333 EN
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