Symptômes
L'erreur 2122 se produit lors de la mise à jour de la protection ou de l'agent de communication de Panda Cloud Office Protection.
Cause
Le fichier de configuration WalUpg.ini est incomplet. L'entrée URL_WEB_GUID dans la section GENERAL du fichier %ProgramFiles%\Panda Security\WaAgent\WalUpg\WALUpg.ini ne peut pas être lue.
Éléments à vérifier
Vérifiez que le fichier de configuration WALUpg.ini est présent dans le dossier correspondant. Pour cela, effectuez les étapes suivantes :
Allez dans %ProgramFiles%\Panda Security\WaAgent\WalUpg
Vérifiez que le fichier WALUpg.ini est présent dans ce répertoire.
Ouvrez le fichier WALUpg.ini et vérifiez qu'il comprend une entrée similaire à http://enterprise.updates.pandasoftware.com/updates_ent/lastupgrade_default_XX_X_XX.html
Solution
Copiez le fichier WALUpg.ini depuis un autre ordinateur dans le répertoire %ProgramFiles%\Panda Security\WaAgent\WalUpg de l'ordinateur affecté.
Si le problème persiste :
Désinstallez l'agent en utilisant l'option Ajout/Suppression de programmes.
NOTE : Vous n'avez pas besoin de désinstaller la protection.
Téléchargez et exécutez l'installeur à nouveau depuis la console de Panda Cloud Office Protection.
Le programme s'installe et détecte si la protection est installée ou pas ou si elle a besoin d'être mise à jour.
Données nécessaires pour rapporter l'incident
Si l'incident n'est pas résolu, vous devez recueillir un ensemble de données sur l'ordinateur. Ces informations seront recueillies de façon automatique par l'outil PSInfo que vous devez télécharger et exécuter en suivant ces instructions :
Depuis un ordinateur connecté à Internet, téléchargez le fichier
PSInfo2_V2.exe sur votre ordinateur et enregistrez-le sur le Bureau Windows.
Double-cliquez sur le fichier PSInfo2_V2.exe, afin que l'outil recueille des informations sur le matériel et les logiciels de votre ordinateur.
Remplissez tous les champs obligatoires.
Si PCOP est installé sur l'ordinateur, l'application PCOPDIAGS se lance.
Suivez les instructions de l'assistant de PCOPDIAGS.
Une fois la collecte de données terminée, un fichier appelé XXXX.psz est généré sur votre disque dur. Envoyez à Panda Security ce fichier, qui est situé par défaut dans le dossier TEMP de votre disque dur.
Dans le cas où, pour quelque raison que ce soit, PSInfo ne peut pas être exécuté, ou si l'application PCOPDIAGS ne s'est pas lancée, vous devez recueillir et envoyer le fichier de configuration WalUpg.ini à l'adresse du service d'assistance technique de Panda Security pour analyse. Ce fichier est situé dans %ProgramFiles%\Panda Security\WaAgent\WalUpg