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(Exemple : “Panda AdminSecure”, “erreur 2093”)
Erreur 1799 lors des analyses à la demande de Panda Cloud Office Protection : une des fonctions exportées par le plugin n'a pas pû être chargée
Ces informations s’appliquent à:
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Produits
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| Panda Cloud Office Protection | | Panda Cloud Office Protection Advanced |
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Symptômes
- L'erreur 1799 se produit lorsque des analyses à la demande sont effectuées depuis la console d'administration web.
Cause
- Une des fonctions exportées par un plugin n'a pas pû être chargée (voir quel plugin dans le message d'erreur).
- Installation incorrecte ou à suppression accidentelle d'un fichier.
- Version du plugin incompatible.
- Fichier corrompu.
Éléments à vérifier
Vérification n°1 : Le fichier plugin n'existe pas
- Vérifiez si le plugin mentionné dans le message d'erreur est inclus dans le dossier d'installation de la protection.
- Vérifiez que le fichier du plugin est dans ce dossier.Si tel est le cas, effectuez la deuxième vérification.
Vérification n°2 : Version incompatible
Dans ce cas, vous devez vérifier que le plugin exporte toutes les fonctions définies pour les plugins WalScan (WA_Initialize, WA_Finalize, WA_GetPluginRevisions, WASCAN_StartScan).
- Éditez le fichier WalScan.ini.
- Recherchez le plugin mentionné dans le message d'erreur dans la section [PLUGINS]
Exemple :
[PLUGINS]
WAC=C:\Program Files\Panda Security\WAC\WASCAN.dll - Une fois le plugin trouvé, vérifiez les dépendances du programme, c'est-à-dire Dependency Walker. Dans cet exemple, le plugin est WASCAN.dll et il exporte correctement les fonctions WASCAN_StartScan, WA_Finalize, WA_GetPluginRevisions, WA_Initialize functions, comme vous pouvez le voir dans la capture d'écran ci-dessous :
Solution
Appliquez la solution correspondant à votre situation :
- Copiez le plugin causant l'erreur dans le bon dossier.
- Désinstallez complètement Panda Cloud Office Protection et réinstallez-le.
Données nécessaires pour rapporter l'incident
Si le problème persiste, envoyez à Panda les données suivantes :
- Le fichier de configuration WalScan (WalScan.ini).
Ce fichier est dans %Programfiles%\Panda Security\WaAgent\WalScan - Le fichier journal WALScan détaillé (une fois l'erreur produite).
Pour obtenir ce fichier journal, effectuez les étapes suivantes :
- Éditez le fichier et ajoutez les lignes suivantes :
[LOG]
LevelLog=2000 - Redémarrez le service Panda Endpoint Administration Agent.
- Pour que l'erreur se reproduise et que vous puissiez recueillir les données, générez une analyse immédiate et forcez une mise à jour pour lancer l'analyse.Pour cela :
- Exécutez la commande waplpmng walconf -force
- Une fois l'erreur reproduite, recueillez les données et envoyez-les à Panda Security.
Numéro d`article d`aide- 20130128 501799 EN